This website requires JavaScript.

promise兼容性问题

2018.04.17 18:10字数 451阅读 324喜欢 0评论 0

先来看了下Promise 的兼容性,如下表

WX201804171805262x.png

网上能找到很多关于promise兼容的解决答案,这里只说vuejs里怎么快捷操作

es6-promise可以解决这个问题,如何使用?

1.安装(安装到dependencies中)

npm install es6-promise --save

2.在入口文件main.js中引入使用

import Vue from 'vue'
...
// cmd方式
require('es6-promise').polyfill()
// ES6模块方式
import Es6Promise from 'es6-promise'
Es6Promise.polyfill()

大功告成,是不是很简单,只需新增而无需删除现有代码,这样对于已经上线的项目是比较安全的